My baby won't start - MustangForums.com



5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
Old 05-27-2013, 07:41 PM   #1
Cobra777
Thread Starter
 
Join Date: May 2013
Location: New Jersey
Posts: 4
Angry My baby won't start

Hey guys,
could use a bit of help. I have a 95 Cobra SVT. Washed and waxed her to take a spin today and all it did was click. It has plenty of power as the lights, radio etc. work fine. Put a jump on it anyway, but did the same thing. Since I don't see a solenoid on the fender, I'm figuring it is on the starter? Anything else it could be? Thanks in advance for the help.
Cobra777 is offline   Reply With Quote
Old 05-27-2013, 08:42 PM   #2
newpony
2nd Gear Member
 
Join Date: May 2008
Posts: 287
Default

battery ground
newpony is offline   Reply With Quote
Old 05-27-2013, 08:43 PM   #3
edwin108
2nd Gear Member
 
edwin108's Avatar
 
Join Date: Dec 2009
Location: New Jersey
Posts: 339
Default

Quote:
Originally Posted by Cobra777 View Post
Hey guys,
could use a bit of help. I have a 95 Cobra SVT. Washed and waxed her to take a spin today and all it did was click. It has plenty of power as the lights, radio etc. work fine. Put a jump on it anyway, but did the same thing. Since I don't see a solenoid on the fender, I'm figuring it is on the starter? Anything else it could be? Thanks in advance for the help.
Your battery may not be strong enough to crank the engine. I would try charging it or bringing it to an auto parts store to be tested. Also, are your battery terminals on tight and free of corrosion?
edwin108 is offline   Reply With Quote
Old 05-27-2013, 08:43 PM   #4
newpony
2nd Gear Member
 
Join Date: May 2008
Posts: 287
Default

Check pos/neg connections
newpony is offline   Reply With Quote
Old 05-28-2013, 05:58 AM   #5
Cobra777
Thread Starter
 
Join Date: May 2013
Location: New Jersey
Posts: 4
Default

Thanks for the replies,
I had tried that route, cleaned connectors all looks good. That's why I am figuring it is the starter.
Cobra777 is offline   Reply With Quote
Old 05-28-2013, 10:37 PM   #6
edwin108
2nd Gear Member
 
edwin108's Avatar
 
Join Date: Dec 2009
Location: New Jersey
Posts: 339
Default

Do you have a volt meter? What is the battery voltage when you turn the key to the start position?
edwin108 is offline   Reply With Quote
Old 05-29-2013, 08:09 PM   #7
Cobra777
Thread Starter
 
Join Date: May 2013
Location: New Jersey
Posts: 4
Default

Decided since she is almost 20 years old with the original starter, it might be a good idea to change the starter anyway. Lots of summer cruising down the shore coming up, and don't want it to go out on me.
Cobra777 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Loud Noise Above 30 MPH bjdutch2005 2005-2014 Mustangs 10 03-24-2017 03:38 AM
2015 Mustang Expansion Tank Granatelli Sales The New S550 2015-2017 Mustang 20 03-16-2017 07:33 PM
Car died while driving... StalkerGT 5.0L (1979-1995) Mustang 13 09-25-2015 02:41 PM
The Future of my GT vintageaion 2005-2014 Mustangs 2 09-08-2015 10:45 AM
5.0 wont start condition 5.0 kevo 5.0L (1979-1995) Mustang 6 09-03-2015 06:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 12:34 AM.