Search



Go Back   MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Sign in using an external account
Register Forgot Password?
Search

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Sponsored by Weld Racing


Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 01-14-2014, 12:27 AM   #1
89stang_2.3
 
Join Date: Sep 2013
Vehicle: 89, Ford, Mustang
Location: Florida
Posts: 3
Default Mustang With Idle Problem HELP!!

Okay i got a 89 mustang 2.3 5 speed. The car has never gave me a problem before till now! Just a few weeks ago the car would die at idle. Once it got down to 1000 rpm it would start to surge and the idle would jump from 500 to 1000 then it would die. It would start up with no problem cold or hot. When i go to take off it would start to jump and then it would take off when i just punch. It would run and drive great once im out of 1st gear but when im driving and if im staying steady at just under 2000 i feel the car acting like its not getting enough air or fuel. I got it to my brothers house and pulled the code on it. Funny thing is that the check engine light has never came on. When i checked it the only codes that popped up was the IAC and EGR. Okay the next day i replaced both of them and its still doing the same thing. Checked the codes again and nothing came up then i checked the compression on each cyl and all of them are at 120 thats good!!!! So I replaced plugs, wires, cap, rotor, ignition coil, distributor, and the TFI. When i did all of that the car was running a little bit better but still acting up. Then i jump to the Vacuum line bought all new hoses and tree. Still acting up. Next i Checked the fuel pressure. At idle the pressure is at between 25 to 28 wen its suppose to be at 30 when its idling. I disconnect the hose from the FPR and the psi would jump to almost 40 with my finger on the hose either way. So i replaced the FPR. The fuel pressure is still the same. Its now holding a idle for a little bit but it still surging and dieing like before. When im at one red light and i go to take off it would just start to jump and carry on and once i just punch it in 1st gear it would clear up it would drive good (still doing like i said in the beginning below 2000) The next light it would take off fine. but still idle like S**t. Everything Ive done to it so far the car has inprove. What else can it be PLEASE HELP!!!
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
89stang_2.3 is offline   Reply With Quote
Old 01-14-2014, 05:05 AM   #2
dawson1112
5th Gear Member

 
Join Date: Jul 2012
Vehicle: 1990 lx hatch 5.0
Location: ohio
Posts: 2,562
Default

You might have better luck posting this in the 4 cyl, section .

If your fuel pressure is still low then I suggest possibly a new fuel filter , or a new pump. You should be getting 35-40 psi at idle with the vacuum hose connected. I suspect its starving for fuel until you drop the hammer , then the vacuum drops off and closes the fpr.
__________________
dawson1112 is offline   Reply With Quote
Old 01-14-2014, 05:05 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 08:44 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup