Search



Go Back   MustangForums.com > Ford Mustang Tech > 2005 - 2014 Mustangs > GT S197 General Discussion
Sign in using an external account
Register Forgot Password?
Search

GT S197 General Discussion This section is for technical discussions pertaining specifically to the V8 variation of the 2005 and newer Ford Mustang.

Welcome to Mustang Forums!
Welcome to Mustang Forums.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread
Old 06-28-2014, 09:37 PM   #11
gregthomas07gt

 
Join Date: Nov 2013
Vehicle: 2007 Mustang GT
Location: Kentucky
Posts: 27
Default

Quote:
Originally Posted by Simon1 View Post
Do they recommend a lower temp thermostat with the tune you are running?
Not sure. C&L won't reply to any of my inquiries. Normal temp runs around 195.

Changed the plugs today, ping is gone so far but the old plugs weren't very bad. The gap was definitely a little wide but not bad. I will say this... between the fuel filter and the plugs, HOLY COW I didn't realize how bad she needed a tune up! Pulls like a mule now! Hopefully the ping doesn't come back.
This ad is not displayed to registered or logged-in members.
Register your free account today and become a member on Mustang Forums!
gregthomas07gt is offline   Reply With Quote
Old 06-29-2014, 08:17 AM   #12
Nuke
6th Gear Member

 
Nuke's Avatar
 
Join Date: Jun 2007
Vehicle: 2007 GT
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 15,945
Send a message via AIM to Nuke Send a message via Yahoo to Nuke Send a message via Skype™ to Nuke
Default

It's a C&L tune (which I originally missed) and my gut tells me that's likely the problem. BAMA or Brenspeed tunes would be my preference.
__________________
Rick
07 GT Prem: Alloy, MT, 3.55's, Steeda CAI w/Brenspeed tunes, FRPP Stingers, 275/40/18 Goodyear Eagle F1 A/S on SVT Cobras (OE GT500's), 14" shorty, Wheelskin side scoops & qtr window louvers, A-H rear window louvers, SHR honeycomb blackout panel, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
06 V6: Legend Lime, Pony Package, 14" shorty, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
Nuke is offline   Reply With Quote
Old 06-30-2014, 12:08 AM   #13
tx_zstang
5th Gear Member
 
tx_zstang's Avatar
 
Join Date: May 2007
Vehicle: 2006 Turbo V6; 2005 V6->V8 swap beast
Location: Central Texas
Posts: 2,330
Default

Indeed...most likely a tune issue as mentioned already :whistle:
__________________
Mike - 2005 Stroked/Forged/Cammed V8 (5.0L.); Kenne Bell 2.6 @ 18psi, + many mods. (formerly a V6 w/Vortech supercharger);
- 2006 4.0 V6 with PH Turbo and TR6060
tx_zstang is offline   Reply With Quote
Old 06-30-2014, 12:08 AM
MustangForums
Ford Mustang




Paid Advertisement

 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising

Featured Sponsors
Vendor Directory
New Sponsors
All times are GMT -5. The time now is 11:21 AM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. Ford® is a registered trademark of the Ford Motor Company
Emails Backup