Pinging Noise Help - Page 2 -

Go Back > Ford Mustang Tech > 2005-2014 Mustangs > GT S197 General Discussion

GT S197 General Discussion This section is for technical discussions pertaining specifically to the V8 variation of the 2005 and newer Ford Mustang.

Pinging Noise Help

Thread Tools Search this Thread
Old 06-28-2014, 10:37 PM   #11
Join Date: Nov 2013
Vehicle: 2007 Mustang GT
Location: Kentucky
Posts: 31

Originally Posted by Simon1 View Post
Do they recommend a lower temp thermostat with the tune you are running?
Not sure. C&L won't reply to any of my inquiries. Normal temp runs around 195.

Changed the plugs today, ping is gone so far but the old plugs weren't very bad. The gap was definitely a little wide but not bad. I will say this... between the fuel filter and the plugs, HOLY COW I didn't realize how bad she needed a tune up! Pulls like a mule now! Hopefully the ping doesn't come back.
gregthomas07gt is offline   Reply With Quote
Old 06-29-2014, 09:17 AM   #12
6th Gear Member
Nuke's Avatar
Join Date: Jun 2007
Vehicle: 2007 GT
Location: PA to KY ('07) to IL ('09) to MS ('10) to FL ('11)
Posts: 16,170
Send a message via AIM to Nuke Send a message via Yahoo to Nuke Send a message via Skype™ to Nuke

It's a C&L tune (which I originally missed) and my gut tells me that's likely the problem. BAMA or Brenspeed tunes would be my preference.
07 GT Prem: Alloy, MT, 3.55's, Steeda CAI w/Brenspeed tunes, FRPP Stingers, 275/40/18 Goodyear Eagle F1 A/S on SVT Cobras (OE GT500's), 14" shorty, Wheelskin side scoops & qtr window louvers, A-H rear window louvers, SHR honeycomb blackout panel, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
06 V6: Legend Lime, Pony Package, 14" shorty, Sequentials, Hella Optilux Extreme XY fogs, Silverstars
Nuke is offline   Reply With Quote
Old 06-30-2014, 01:08 AM   #13
5th Gear Member
tx_zstang's Avatar
Join Date: May 2007
Vehicle: 2006 Turbo V6; 2005 V6->V8 swap beast
Location: Central Texas
Posts: 2,369

Indeed...most likely a tune issue as mentioned already :whistle:
Mike - 2005 Stroked/Forged/Cammed V8 (5.0L.); twin-turbos . [previous: 2.6 KB, in sig pic]
- 2006 4.0 V6 with PH Turbo and TR6060
tx_zstang is offline   Reply With Quote


Similar Threads
Thread Thread Starter Forum Replies Last Post
What other parts should I be concerned about if my pinion bearing went bad? KingRando 2005-2014 Mustangs 5 10-02-2015 09:06 AM
95 Mustang 3.8L Front end noise issue Ghost_Conscience V6 (1994-2004) Mustangs 0 09-23-2015 03:17 PM
1995 Mustang GT RAM HDX / TOB noise problem after install? ccdguy 5.0L (1979-1995) Mustang 1 09-19-2015 06:20 PM
Loud Noise Above 30 MPH bjdutch2005 2005-2014 Mustangs 8 09-07-2015 11:05 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 11:25 PM.

This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company