Lower contol Arm noise - MustangForums.com

Notices
4.0L V6 Technical Discussions Any questions about engine, transmission, exhaust, tuners/CAI, or gearing can be asked here!

Lower contol Arm noise

Reply

 
 
 
Old 06-11-2011, 11:31 PM
  #1  
Rshustler1
2nd Gear Member
Thread Starter
 
Join Date: Apr 2011
Location: Texas
Posts: 242
Default Lower contol Arm noise

Hey guys I know this is repetitive somewhere but I need some knowledge here, I just instAlled some uhr lower control arms that are double adjustable , which is done by either bolting them tighter to shrink the length or looser to extend them, I have them adjusted to the correct length and the second adjustment is that they swivel in the bearings. Now the problem I am am having is when I am cruising at a stable speed like a steady 60 and then I step on the gas hard it makes a noise like a pop and jerks the car. Does anyone here know why? I assume because the lca swivel and that's the swivel, will this hurt my power to traction?
Rshustler1 is offline  
Reply With Quote
Old 06-12-2011, 05:32 PM
  #2  
JimC
Moderator
 
JimC's Avatar
 
Join Date: May 2006
Location: North Carolina
Posts: 7,155
Default

When you installed them did you load the suspension before you torqued them down? If not, then you may be getting some binding
JimC is offline  
Reply With Quote
Old 06-13-2011, 02:36 AM
  #3  
Rshustler1
2nd Gear Member
Thread Starter
 
Join Date: Apr 2011
Location: Texas
Posts: 242
Default

I had put the jackstands underneath the axle to put a load on the suspensio, is that what u mean?
Rshustler1 is offline  
Reply With Quote
Old 06-13-2011, 05:50 AM
  #4  
JimC
Moderator
 
JimC's Avatar
 
Join Date: May 2006
Location: North Carolina
Posts: 7,155
Default

That will load it, so you shouldn't have an issue with binding because you followed the proper procedure. So that eliminates one possibility.

Now we just need everyone's thoughts on other possibilities to check next.
JimC is offline  
Reply With Quote
Old 06-14-2011, 02:29 AM
  #5  
Rshustler1
2nd Gear Member
Thread Starter
 
Join Date: Apr 2011
Location: Texas
Posts: 242
Default

My alignment was Off like on any suspension mod so I went to get it aligned, not even driving 10 mile and it started to pull again so im retiring them for some steedas
Rshustler1 is offline  
Reply With Quote
Old 06-14-2011, 06:57 AM
  #6  
2005Redfire6
6th Gear Member
 
Join Date: Jul 2008
Location: Acworth, GA
Posts: 12,260
Default

That is very odd that it can bind that much and cause the car to pull, something ain't right! And do you mean UPR?
2005Redfire6 is offline  
Reply With Quote
Old 06-15-2011, 03:28 AM
  #7  
Rshustler1
2nd Gear Member
Thread Starter
 
Join Date: Apr 2011
Location: Texas
Posts: 242
Default

Ya my bad upr
Rshustler1 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
baddog671
Parts For Sale
20
07-26-2016 01:20 PM
lincolnshibuya
V6 (1994-2004) Mustangs
3
10-07-2015 09:01 PM
UrS4
S197 Handling Section
10
10-03-2015 06:23 AM
KingRando
2005-2014 Mustangs
5
10-02-2015 08:06 AM
UrS4
S197 Handling Section
1
09-30-2015 10:13 AM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory