help me with my blower motor - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Reload this Page >

help me with my blower motor

5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

help me with my blower motor

Reply

 
 
 
Old 11-02-2009, 08:57 PM
  #1  
gregamuffin
1st Gear Member
Thread Starter
 
Join Date: Mar 2008
Posts: 149
Default help me with my blower motor

I live in buffalo, ny which as you should know, about this time of the year is COLD. my blower motor worked all summer and i had no ac so i had no use for it i went to use it for the first cool day and it took a dump on me. no big deal ive replaced one on a crown vic once before i thoguht it should be a cake walk. i bought the new one and after a month got around to trying to installing it today. i got the old one out and off, put the new one in and spliced the wires and reconnected the connector and the hose and the vacuum line and it doesnt work. what did i do wrong? is it in place wrong is there a common mistake i could have fallen victim to? ive been dealing with the cold ok but not being able to defrost my windows is downright dangerous and a nuisance!
gregamuffin is offline  
Reply With Quote
Old 11-02-2009, 09:40 PM
  #2  
mjr46
D.R. THE PATHETIC DORK
 
mjr46's Avatar
 
Join Date: Jun 2007
Location: West Virginia
Posts: 30,808
Default

bwahhaaaaaaaa haaaaaaaaaaaaa, your common mistake you fell victim to was not troubleshooting the system properly to narrow it down to a faulty component, you assumed it had a bad blower motor, get a diagram and go point to point in the system, check fuses and test switch and blower motor resistor
mjr46 is offline  
Reply With Quote
Old 11-03-2009, 01:57 PM
  #3  
gregamuffin
1st Gear Member
Thread Starter
 
Join Date: Mar 2008
Posts: 149
Default

man you are a ballbreaker but thanks nonetheless and could someone post up a diagram?
gregamuffin is offline  
Reply With Quote
Old 11-03-2009, 05:09 PM
  #4  
PRO50SC
The Rogue Mod
 
PRO50SC's Avatar
 
Join Date: Feb 2006
Location: Maryland Sucka's!!
Posts: 21,918
Default

Originally Posted by gregamuffin View Post
man you are a ballbreaker but thanks nonetheless and could someone post up a diagram?
Year of the car would help.
PRO50SC is offline  
Reply With Quote
Old 11-03-2009, 05:27 PM
  #5  
gregamuffin
1st Gear Member
Thread Starter
 
Join Date: Mar 2008
Posts: 149
Default

it's a 1990 lx sorry
gregamuffin is offline  
Reply With Quote
Old 11-05-2009, 06:31 PM
  #6  
gregamuffin
1st Gear Member
Thread Starter
 
Join Date: Mar 2008
Posts: 149
Default

well i appreciate the advise as usual but the problem has been fixed and i have no idea how lol this morning with the car running and the blower motor clearly not running like usual i slammed my door shut and all of a sudden it roared to life on all the settings and has worked all day. im not complaining but i have no idea what needed to be jostled like that any ideas?
gregamuffin is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
firehorse02
Parts For Sale
1
11-16-2015 11:28 AM
UrS4
S197 Handling Section
10
10-03-2015 06:23 AM
Explosive
Street/Strip
17
10-02-2015 07:45 AM
Drastang
4.6L (1996-2004 Modular) Mustang
2
09-30-2015 03:48 AM
logan409
4.6L (1996-2004 Modular) Mustang
10
09-26-2015 07:43 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory