Distributer help WTF am I doing wrong - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 5.0L (1979-1995) Mustang
Reload this Page >

Distributer help WTF am I doing wrong

Notices
5.0L (1979-1995) Mustang Technical discussions on 5.0 Liter Mustangs within. This does not include the 5.0 from the 2011 Mustang GT. That information is in the 2005-1011 section.

Distributer help WTF am I doing wrong

Reply

 
 
 
Old 09-18-2010, 08:37 PM
  #1  
s0lidllama
Thread Starter
 
Join Date: Apr 2010
Location: LA
Posts: 33
Default Distributer help WTF am I doing wrong

First off, I want to say I know there are a million different articles asking this same question. I've read them and still cant figure this out.

So I'll list step by step what I'm doing and if someone could tell me where I'm f-ing up, 1,000 internets will be your reward.

Pull #1 spark plug
Spin engine crank clock wise till I feel air pushing out of plug hole
Line up with 0 TDC
Reinstall spark plug and wire
Drop dizzy in making sure rotor lines up with #1 terminal on cap
Bolt down
Start car
Adjust timing

With all that being done, car still sputters and back fires. I can get the engine to start but it sounds like its chugging. From my understanding the chugging could be because it might be 180 degrees backwards. But how can it be backwards when I feel the air pushing from the socket?

The car WAS running. I'm using the same distributor and all the same parts.
Also, Its an MSD Pro Billit. Theres no #1 terminal imprinted on the cap. That shouldnt really matter as long as the rotor is lined up with #1 terminal at TDC right?

Thanks in advance.
s0lidllama is offline  
Reply With Quote
Old 09-18-2010, 09:00 PM
  #2  
enix187
3rd Gear Member
 
enix187's Avatar
 
Join Date: Apr 2007
Location: NC
Posts: 590
Default

check your firing order, I think its 1-3-7-2-6-5-4-8, and then with it running try and check the timing and see which way its out, then rotate the distributor the appropriate direction, be careful and do it quickly or the consequences will never be same
enix187 is offline  
Reply With Quote
Old 09-18-2010, 09:40 PM
  #3  
Bubba 95SN
4th Gear Member
 
Join Date: Apr 2009
Location: N.C.
Posts: 1,893
Default

Da firing order is counterclockwise. You can always just pull valve covere and watch valves to determine #1 on compression stroke.
Bubba 95SN is offline  
Reply With Quote
Old 09-18-2010, 11:34 PM
  #4  
s0lidllama
Thread Starter
 
Join Date: Apr 2010
Location: LA
Posts: 33
Default

Man Im stupid. I cant believe I overlooked that. I mustve looked at it and and thought something didnt look right a dozen times but couldnt figure it out. I had #7 and #4 plugs backwards. Doh!

Now my problem is the little pin inside the distributor well wont let me set the dizzy flush. No quick fixes for that right? just try to move the pin around till it sits right?
s0lidllama is offline  
Reply With Quote
Old 09-19-2010, 09:23 AM
  #5  
Gary H
4th Gear Member
 
Join Date: Mar 2007
Location: Chandler, Az
Posts: 1,080
Default

You mean the oil pump drive? Bump the engine over and it should drop right in.
Gary H is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mr. D
Off Topic
833
06-19-2016 03:04 AM
Dokilar
4.6L (1996-2004 Modular) Mustang
15
10-16-2015 09:13 PM
Matt's 95 Stang
5.0L (1979-1995) Mustang
2
10-05-2015 08:16 AM
ChampInSD
5.0L GT S550 Tech
13
10-02-2015 05:55 AM
marc954
4.6L (1996-2004 Modular) Mustang
2
09-29-2015 12:18 PM


Thread Tools
Search this Thread
Quick Reply: Distributer help WTF am I doing wrong


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.