turn signal problem - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > General Tech
Reload this Page >

turn signal problem

General Tech Ask model specific questions in the appropriate category below. All other general questions within.

turn signal problem

Reply

 
 
 
Old 11-14-2003, 02:53 PM
  #1  
97FordGT
1st Gear Member
Thread Starter
 
Join Date: Oct 2003
Location: United States
Posts: 97
Default turn signal problem

my flasher goes really fast and only my left rear signal works. the front one doesnt. i replace the bulb but still doesnt work. any ideas
97FordGT is offline  
Reply With Quote
Old 11-15-2003, 12:00 PM
  #2  
97FordGT
1st Gear Member
Thread Starter
 
Join Date: Oct 2003
Location: United States
Posts: 97
Default turn signal problem

nevermind i found the problem. actually my dad did. cleaned the socket and what do u know. guess it was corroded or somethin. peace
97FordGT is offline  
Reply With Quote
Old 11-18-2003, 09:19 PM
  #3  
Black Horse
3rd Gear Member
 
Join Date: Sep 2003
Location: United States
Posts: 751
Default turn signal problem

whenever it blinks fast...that is to let you know a bulb is not working..wether its the bulb itself or the socket in your case...just fyi
Black Horse is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
musnicki
Classic Mustang General Discussion
8
09-23-2015 07:11 AM
5.0 kevo
5.0L (1979-1995) Mustang
6
09-03-2015 06:24 PM
Nurdyguy
Classic Mustangs (Tech)
5
09-03-2015 05:48 PM
cbird1177711
2005-2014 Mustangs
3
09-02-2015 08:51 PM
iculookin
GT S197 General Discussion
0
09-02-2015 12:34 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory