Gauges randomly quit on me - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > General Tech
Reload this Page >

Gauges randomly quit on me

Notices
General Tech Ask model specific questions in the appropriate category below. All other general questions within.

Gauges randomly quit on me

Reply

 
 
 
Old 12-06-2018, 05:47 PM
  #1  
jasper_roberts99
Thread Starter
 
Join Date: Dec 2018
Location: Alabama
Posts: 1
Default Gauges randomly quit on me

Hello, I have a 97 mustang and here lately the temperature gauge, gas gauge, and rpms will randomly quit on me. After driving for awhile they'll usually slowly start to work again, but its starting to happen more and more and taking longer to come back. Any ideas? The other gauges are fine and haven't had an issue. Im relatively inexperienced so I figured I'd get some opinions before throwing money at it.
jasper_roberts99 is offline  
Reply With Quote
Old 12-07-2018, 10:32 AM
  #2  
Buck Sergeant
2nd Gear Member
 
Join Date: Aug 2017
Location: North Carolina
Posts: 436
Default Gauges randomly quit on me

jasper_roberts99, I'm thinking a ground strap/wire is working loose. These three gauges probably have a common/shared ground. Locate the ground wire and make sure the grounding location is clean, also clean the "eyelet," and then reattach the wire to whatever it is attached to.
Buck Sergeant is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
AlloySixxer
2005-2014 Mustangs
14
07-13-2010 10:38 PM
Fink
V6 (1994-2004) Mustangs
16
04-10-2010 10:42 AM
blowngt
2005-2014 Mustangs
17
09-10-2007 04:11 PM


Thread Tools
Search this Thread
Quick Reply: Gauges randomly quit on me


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.