2010 GT: Chiped Paint - MustangForums.com

Go Back  MustangForums.com > Ford Mustang Tech > 2005-2014 Mustangs
Reload this Page >

2010 GT: Chiped Paint

Notices
2005-2014 Mustangs Discussions on the latest S197 model Mustangs from Ford.

2010 GT: Chiped Paint

Reply

 
 
 
Old 07-03-2010, 06:46 PM
  #1  
SirDrums
2nd Gear Member
Thread Starter
 
Join Date: Nov 2009
Location: Alabama
Posts: 180
Default 2010 GT: Chiped Paint

It been raining alot here in bama the last month or so and today was the first day that it hasn't rained and I was free enough to wash the GT.

Every thing was going good until I got the the front of the car and I noticed what I thought was a very small bug or what looked like a piece of lint (white) after scrubbing on it I came to realize that it was the primer (I think) and some paint had flaked off. Since then I found two more spots on the front that are doing the same.

I am hoping a simple repair could work like getting a paint pen from the dealer and then painting/waxing it.

These spots are really small and are really only noticable when the car it very clean and a white spec stand out against the Kone blue paint.

Anyone else had this happen? How did you fix it?
SirDrums is offline  
Reply With Quote
Old 07-03-2010, 07:17 PM
  #2  
2cokeman
5th Gear Member
 
2cokeman's Avatar
 
Join Date: Feb 2007
Location: Ontario,Canada
Posts: 3,471
Default

We need to see pics please!
2cokeman is offline  
Reply With Quote
Old 07-03-2010, 07:28 PM
  #3  
ShaneM
5th Gear Member
 
ShaneM's Avatar
 
Join Date: Jun 2009
Location: Texas
Posts: 2,397
Default

you know, i was wasing my car last weekend and noticed right by the weather stipping on teh door above the passenger handle a pieceof paint had just chipped off. My mom has a 10 fusion and she has o ne palce on it that did the same thing. teh shat is that i can;t find grabber blue touch up paint anywhere. ford place will order it.
ShaneM is offline  
Reply With Quote
Old 07-03-2010, 09:16 PM
  #4  
jhawkr
2nd Gear Member
 
jhawkr's Avatar
 
Join Date: Apr 2010
Location: Kansas
Posts: 240
Default

I think there are some issues with some of the new water-based paints. I have a chip on my 2010 with 2200 miles on the edge of the hood. Candy Red Metalic. Probably the best bet to repair it is a Ford touch-up kit.
jhawkr is offline  
Reply With Quote
Old 07-03-2010, 09:39 PM
  #5  
mikenavy
1st Gear Member
 
mikenavy's Avatar
 
Join Date: Oct 2009
Location: Sparta
Posts: 110
Default

My grabber blue has about 6k miles. Probably 4-8 random paint chips throughout the body of the car. And the painted alloy 19inch wheels have a paint flaking off the edges also. Pretty ****ty quality imo.
mikenavy is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Galactic
Mustangs For Sale
9
03-30-2017 06:44 PM
MustangForums Editor
The New S550 2015-2020 Mustang
1
10-01-2015 09:29 AM
mungodrums
The New S550 2015-2020 Mustang
10
09-28-2015 10:54 PM
GLOCKer
General Tech
0
09-28-2015 07:36 AM
mustangchef
New Member Area
7
09-04-2015 08:08 PM

Forum Jump

Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory